2014年8月 的存档
2014八月26

LNMP升级php后502 Bad Gateway解决方法

今天购买了imobitrax, 准备在linode上安装(基于LNMP),于是把php从5.2升级到了最新的5.5.16,之后发现php 5.5.16不支持,又降级到了5.3.29。成功升级后却出现502 bad gateway. LNMP上的其他网站也出现同样的错误。

后来百度之,找到解决方法:

/usr/local/php/etc/php-fpm.conf里listen下面添加上
listen.backlog = -1
listen.allowed_clients = 127.0.0.1
listen.owner = www
listen.group = www
listen.mode = 0666
重启php-fpm

继续阅读……