168IT网 > WordPress教程 > wordpress无法更新、安装插件,提示填写FTP信息的解决方法
2012四月21

wordpress无法更新、安装插件,提示填写FTP信息的解决方法

在LNMP上面搭建wordpress博客的时候,经常会遇到wordpress无法在线升级,也无法在线安装或者更新插件,会弹出输入FTP信息的输入框界面。开始也被这个问题困扰了很久,后来在LNMP网站上面找到了解放方法——把权限设置给www用户组。

据LNMP一键安装包使用者反映wordpress提示升级时,点“自动升级”出现填写FTP信息的页面,像我们这些用LNMP的很多都不安装FTP服务器。其实出现这个的问题就是Nginx的执行身份非文件属主身份。

解决方法:

假设你的wordpress安装目录为/home/wwwroot/lnmp.org

用Putty登录Linux VPS,执行:chown -R www /home/wwwroot/lnmp.org

执行上面的命令就可以将/home/wwwroot/lnmp.org下所有文件的属主改为www,这样就可以解决自动更新必须填FTP的问题。

文章来源:168IT网
本文地址:http://www.168itw.com/wordpress/lnmp-ftp/
版权所有 © 转载时必须以链接形式注明作者和原始出处!

One Response to “wordpress无法更新、安装插件,提示填写FTP信息的解决方法”

  1. #1 wordpress 回复 | 引用 Post:2012-05-25 23:13

    一直弹出填写ftp信息框,终于搞定了,害得我之前升级都不敢。

发表评论